Back to the main site

[Answered]World of Warcraft - High framerate but choppy in some scenarios


#1

WoW works great with Wine + DXVK, but even with high framerate (100+) I feel everything slow down when certain effects are on screen. Like intense smoke/debris/fire.

The interesting thing is that the framerate reported by the game is still equally high through it all, so I’m really wondering what could be causing it and where to report it.

Note; reducing some graphics settings helps reduce the chopping significantly, but I would still be interested in figuring it out :slight_smile:


#2

Smoke/debris/fire always has been the bane of nvidia cards. It is already slightly better when they changed it in 7.3.5 with newer animations (which broke dx9), but still not good.

Particle density (Spell richness, smoke, gas)
Liquid Details (Water, lava, fireground effects)

I usually have it on 7 with my GTX970 and 2560x1440. Then I have a bg / raid profile with preset 7, but that sets those 2 settings lower. Seems to work for me.


#3

I’m on AMD (mesa).

So far my game runs perfectly on 10 as long as I reduce SSAO. So it’s likely just a driver inefficiency?


#4

I found turning down shadows all the way has the biggest impact for me. But Raids… that’s a different story all together!!! Windows or Linux. AMD or Nvidia. Same results. I’d hate to see how 4k would perform for me.


#5

WoW engine is terrible, the way they coded it, every effect is in fact an “invisible npc” doing something. When a lot happens fps drops. But yeah, some stuff is just hard on GPU. Just figure out what it is for your card and live with it for now.

DX12 could fix it though, which could translate well into Vulkan for near native performance on Linux. I hope. I haven’t looked into Wine with vkd3d yet.


#6

I’m seeing the same on my AMD (mesa). I’ve never had those high framerates under windows which I have now but whenever there’s effects the game stutters. My settings are already as low as possible.

For Dx12 or vulkan I’d have to buy a new card.


#7

You can try the esync build. That reduces some overhead, and should help.


#8

The game seemed to be choppy for me even though i had 80+ fps (running on AMD Vega 11 on DXVK). Enabling VSync fixed it for me.


#9

I’m not sure why the esync wiki tells users to edit /etc/security/limits.conf. I’ve read https://github.com/zfigura/wine/blob/esync/README.esync which says that limits.conf will be ignored by systemd (which is the init system most linux distros have). Also on my debian system “ulimit -Hn” already returns “1048576” so why should I try to reduce that value?

Anyway, I followed the rest of the wiki and I’m testing this.

Edit: FPS are starting to jump wildly in between 5 and 70 fps


#10

I have systemd, and I changed limits.conf for my user and it worked fine. So it might depend on the system you are using. I figure Debian / Ubuntu etc set it with systemd, while my Arch still uses the limits.conf.

Btw: Feel free to correct the wiki, thats why it is a wiki.


#11

Thanks for giving solution to this.