Anno 1800 Corrupting Savegames -> related to old WoW DXVAVDA Error?

Hi all,
I’m trying to fix Anno 1800 (again) and I’m definitely out of ideas this time and need help from people who actually know what they are doing >.<
First, I’m not very adept at navigating through the mazes of linux and wine specifically and english is not my first language, so please be patient with me and thank you very much in advance for your help :heart:

manjaro, runner lutris-6.14-2-x86_64
lutris -d: Ubuntu Pastebin
lutris --submit-issue: Ubuntu Pastebin
lutris logs: can only post two links apparently, so ask for this if needed, please

So this is what I gathered:
Game was running yesterday, crashed, savegame doesn’t start up again, no error message whatsoever, as usual. It crashes quite regularly (every few hours) so I didn’t think much of it at that time and just quit for the day. I’m aware that workarounds such as wine in general tend to come with crashes, so that’s not what I’m whining about here, mind you, these things just happen, I know.

Since then I tried different runners to fix this (switching back and forth did work multiple times before if the game crashes but the savegame survives, different runners might reinstall stuff or smth?) and updated graphic drivers n stuff and I got it from crashing inside the loading screen for a save game to loading parts of the map and crashing then (yay…).
Starting a new game does work, but I already lost the last two savegames to such bs and I’m tired of starting over and over again, so this time I’m trying to fix the issue in hopes of helping others with similar issues.

  • One savegame I lost was much more advanced than the other, so I can’t really see any similarities between crashes and/or corruption there, but I did have at least ~8 hours in each savegame before corruption. Crashes going from once half an hour to maybe 3 to 4 hours.

  • An exception is a general issue with the trading routes menu, crashes quite often there, but that never corrupted files, so that should be something else. Probably routing logic going astray while deleting route points, if I had to guess.

  • I noticed the DXVAVDA issue in these logs but I don’t know what that is or how to fix it, I guess it’s related to DXVK? Switching that on and off doesn’t help, though. I also tried the NVIDIA Prime Render Offload, no luck either, found that apparently helped for a similar issue in the past regarding WoW →

  • While googling I noticed that WoW on Lutris did had similar sounding log messages at some point, but didn’t found anything to fix my issue there and WoW runs perfectly fine for me, at least most of the time, but runner is and always was lutris 6.0 here

  • For the last few days I noticed a texture bug sometimes, some of the ground texture was replaced with plain green, maybe that’s also related? Didn’t happen before the first corrupted file, though and doesn’t seem to be connected to chrashing. Just looks weird.

  • One of the corrupted files was hours into the new tourist dlc without an issue, the other didn’t start on it at all

I do say corrupted files in want of a better description here, but this actually is a savegame inside the cloud, so I doubt it’s really “corrupted” as in “file unreadable”. Just “not loadable here”, might be perfectly fine on another system, though. Dunno.
Edit: I tested it on win on another system, it didn’t load, looks exactly the same as on my system, so seems it really is corrupted.

System and versions:
I run lutris on manjaro and I switch between the wine runners regularly, choosing the best working one, which is sadly quite rarely staging. This issue is consistent on all of them, though, if the game starts at all, of course. Originally, I ran the standard install script provided on the lutris website (only two links allowed, but first post on google “lutris Anno 1800”). I changed some options around, trying to fix things and the runners ofc, as mentioned, but nothing more complex that what the lutris GUI provides, except there was a reddit post somewhere with some additional libs wine needed upon installation. Worked with that for almost a year now, more that 100 hours playtime, I’d guess.

Thank you for your attention and thank you for any help or insights you might provide in advance :slight_smile: