Back to the main site

All Games Crashing w/ Alt-tab

Hi Everyone!

I recently moved from Kubuntu 18.04 LTS to Manjaro 19 w/ KDE Plasma. Manjaro is great, games seem to run more efficiently in Manjaro and I love the rolling updates. The trouble is, it seems that frequently when I alt-tab, the whole system locks up and I have to hard boot. It’s not every time but after a few alt-tabs-- toast. This was not at all an issue with Kubuntu. At first I was trying out ACO on a bunch of games but this is now disabled and the issue persists. Any advice? Perhaps it’s a memory issue? I’m not even sure if it’s a Lutris-specific problem as I think it’s also happened with Steam games.

I have AMD FX-8320 and Radeon RX 570 4GB, 8GB System Ram, WoW and Manjaro running off of SSD (same as Kubuntu).

Thank you in advance for any support you can offer.

This used to happen in Windows too. When desktop has differend settings than the game. Then it is also difficult to switch between game and system using alt tab. I gues you don’t have troubbles using alt tab to switch applications and the problem only appears when switching from game to system? Maybe it was just caused by an game setting? :mask:

With Wine/DXVK/Proton, a virtual desktop seems to help (solves a lot of input issues for me as well), and if you put in your native resolution it functions just like a fullscreen game. Also if it’s “just” the game window hanging, you can set up a shortcut for xkill to kill the window.

However I would suspect the root cause is a compositing issue with the KDE window manager kwin, probably this 3 year old issue or something similar: https://bugs.kde.org/show_bug.cgi?id=373615

So I’d try the virtual desktop setting in Lutris, and if necessary tinkering with compositing in the KDE menu might help as well. If no joy consider using a different window manager with KDE if possible, or try a whole different desktop environment and window manager; a pain, yes, but it will likely fix the issue.

I’m going to agree with SenileAnimal on this one. I’m also going to point out that Lutris runs steam games as well, so if the problem IS a lutris issue (doubtful), and you run steam games using Lutris, then you can’t rule out Lutris as being the problem, because Lutris is the one launching the games through steam.

Your problem does sound like the KDE bug mentioned in the previous comment, so i would start there. :slight_smile:

Hi both!

Thanks so much for your suggestions. I’ve been super busy and haven’t been able to try this out until the past few days. Looks like the virtual desktop did not help WoW at least. I haven’t tried other games but what I did notice is that the past two crashes (virtual desktop or not) have happened when I alt+tab and then open Firefox, that’s what crashes it. I’m wondering if it’s a memory issue? After the crash in the virtual desktop, I ran WoW again with no issue without the virtual desktop and with ACO enabled for a couple of hours.

I’m stumped! Couldn’t find anything in the crash log either. Maybe this is how the bug works? Thanks for your initial insights, y’all. If this continues, I might switch over to Ubuntu again and see how it rolls.