Back to the main site

Aion online error after installation


#1

Hello,
after installing and updating Aion (dxvk version) there is some error which prevents me from playing the game.
Lutris -d:
https://paste.ubuntu.com/p/wqz74NN7PM/

neofetch:
https://paste.ubuntu.com/p/V9jzsKvR3H/


#2

there’s a problem with your dxvk 0.90 version, either delete it and redownload it or change it to a newer version like 0.93


#3

that would seem like noob question but: how do i delete dxvk version?
EDIT: changing it to version 0.93 produces exactly the same error but with 0.93 instead of 0.90


#4

Additional note: game installed and patched successfully, but i cannot launch Aion again because of above error


#5

please check in ~/.local/share/lutris/runtime/dxvk if the dxvk libraries did download correctly


#6

https://paste.ubuntu.com/p/gwgM7PfmNV/
version 0.90 has only x64 directory with the same files (different filesizes though)


#7

if you see a DXVK that seems weird, delete it and let lutris re-download it.


#8

i deleted dxvk folder and lutris redownloaded it, but the outcome was the same
https://paste.ubuntu.com/p/ycMbQJ6QQ9/


#9

You probably have a broken symlink in your game folder. Look for dxgi.dll and delete those files.


#10

No difference after deleting dxgi.dll. The same after copying this file (nevermind if x32 or x64) from different directories


#11

I meant the libraries in the wine prefix, which are likely to be broken symlinks.

Check [GAME DIR]/drive_c/windows/system32/dxgi.dll and see it that’s what is causing the issue.


#12

https://paste.ubuntu.com/p/yPwMwd8YT6/
File has 3,5K where in different directories it has at least 1,5M …
I have tried previously to copy these bigger files to the place you mentioned but for nothing :expressionless:


#13

Can you get other DXVK games running in a fresh prefix?


#14

They are working fine: warframe, path of exile and frostpunk


#15

so it seems that you just have stale symlinks in your prefix

find all files named dxgi.dll and d3d11.dll in your prefix, and try relaunching


#16

I deleted files you recommended and couple more associated with directx (dll files).
Now log is more meaningful
https://paste.ubuntu.com/p/84PwwzXFPK/


#17

You have the lutris runtime disabled.


#18

There is progress. Game now starts launcher and patches. After successfully patching the game i clicked run the game and basically nothing happened. Launcher window closed and thats it.
Lutris -d:
https://paste.ubuntu.com/p/36Bk5TKj6Z/
Wine last game log:
https://paste.ubuntu.com/p/85PCdWyHJb/