Adding some not easily available Windows DLLs

I would like to make a Lutris install script for Yousician. It is quite tricky to make it run in wine. One of the problems is solved by using wine-staging (one of the patches there is needed), but the other is that the app requires two DLLs from Windows 7 – mfplat.dll and MFPlay.dll, and right versions of them. Those are not available via winetricks, and the official way to get them (Media Feature pack) is only available as an msu archive which even wine-staging cannot install.

The files can be found and downloaded from some more-or-less shady sites, e.g. from

Can I use such download sites directly from the install script or should the user be asked to provide the DLL files? Is there a way to ensure the files have proper MD5 sums?

Can’t you just extract the msu and grab the two .dll’s? Drop it in your C:\Windows\System32 or syswow64 if it’s 64bit. Run regsvr32 filename.dll. Might have to run it as admin, but IDK how wine handles elevated commands for windows.

Edit: Oh you want to make your own script. Well grab the dll’s, host them on github or something, and have the script jgrab them from there. No check sum needed then if the source is from you.

Can’t you just extract the msu and grab the two .dll’s?

AFAIK there is now way to extract the MSU in Linux or Wine. It uses the proprietary ‘delta’ compression, which is not supported by any Linux tool.

I already have the DLLs and have Yousician running, but I want to make a Lutris script to make it easy for other users.

I would rather not host copyrighted files on my own account – I am quite convinced that this would not be legal. If other site (like wikidll) doesn’t see a problem with it, I am happy to use their services. :wink:

I consider my own hosting for a wineasio binary, which could also be useful for Yousician in wine, but wineasio is open source, so that won’t be a problem.

I’m atm struggling to get Yousician running. It at least starts on >=Wine 4 but I end up with the error message “Unable to play the video. Are you connected to the internet?” (or in Wine 4.8 simply buffering forever)

Does the current version of Yousician work for you?
It would be great to have a script for installing it or at least an instruction.

There is nothing on the internet about it, only angry people at their forums complaining about kicking linux support…
It doesn’t even have an entry at wineHQs AppDB

Unfortunately, even one of the install that used to work for me stopped working recently.

I have never seen the “Unable to play the video. Are you connected to the internet?” message, though. For me it would just crash whenever it tried to play a video.

Do you have any access to working Windows instance of Yousician, logged in to your account. If so, then try copying the AppData/LocalLow/Yousician/Yousician/Cookies/Library file from Windows to your .wine prefix. This should allow you to skip the login video.

1 Like