A bug with DX support in lutris

Hello, everyone!
I encountered a bug with dx12 when trying to launch Atomic Heart today [dxvk, vkd3d enabled, Windows version is set to 10]:

DX12 is not supported on your system. Try running without the -dx12 or -d3d12 command line argument.

When running the game with -dx11 argument:

A D3D11-compatible GPU is required to run the engine

I’m on Ubuntu 22.04.2 LTS x86_64
Intel i3-6006U (4) @ 2.000GHz
Using discrete vc NVIDIA GeForce 920MX
Having the latest proprietary driver nvidia-driver-525

I tried to run an elder game then (Progect I.G.I., 2000) and got an issue

This application requires DirectX version 7.0 or greater to run.

World of Tanks says:

Application has failed to start because no appropriate graphics hardware acceleration is available or it is turned off

Crysis 3 throws

terminate called after throwing an instance of ‘dxvk::DxvkError’
Exit with return code 768

Disabling dxvk in settings changes nothing.
I tried almost every lutris wine build (proton and non-proton).
These apps issue no errors when are run with the terminal so the problem is in lutris.
Could anyone advise sth to me please ^U^

1 Like

You will need to have Advanced view enabled in Lutris settings (Runner Options) to see this, but verify that the configured versions of DXVK and VKD3D-Proton in those fields actually exist.

/home/yourname/.local/share/lutris/runtimes, dxvk and vkd3d subdirectories

By the way, if you need newer versions of those, you can download and unpack them and drop them in those subdirs, then change the fields in Runner Options to use them. (You can actually type in that drop list)

I’ve got the latest versions of dxvk [1.10] and Vulkan [2.8] that are installed properly
The problem with lutris had taken place after i upgraded the kernel yesterday. Apt-get automatically installed some lib-amd* libraries (for nvidia card), so i have just removed them all and reinstalled the nvidia driver.
The problem is solved. Now i may even enjoy playing Atomic Heart at 2-3 fps ^)
Thanks for your help, Grogan

2 Likes