Back to the main site

6fps Borderlands (Epic) on hybrid-intel-nvidia-prime

I’m trying to run Borderlands 3 launching the Epic Store with Lutris on a Surface Book 2 using the video-hybrid-intel-nvidia-440xx-prime drivers. My frame-rates are very low. With low resolution and graphics settings on low, I get about 6fps. I need help configuring Lutris. Should I be using Vulkan? Launching Lutris with or without prime-run doesn’t seem to make any difference in render speed.

Here’s my lutris-issue-report.json and debug log.
https://paste.ubuntu.com/p/r3jTfdW7bF/

Thanks for any help you can give.

I also remember that in Windows when playing games the GPU fans would kick in and get loud. I haven’t heard that in Linux. I’m assuming there’s some kind of performance level adjustment that I need to do manually?

I’ve been reading about GPUPowerMizerMode, but nvidia-settings --query all doesn’t show any parameters I can change. Can I not access those controls because I am going through the igpu?

I think you are having the same problem that I’m just now finding. The Epic games launcher ignores the prime-run thing for some reason, even when set in the lutris system options, and runs games with the default video adapter (integrated graphics in your case). You can verify this by looking in the the launcher’s logs at “/path/to/epic/wine prefix/drive_c/users/<user>/Local Settings/Application Data/EpicGamesLauncher/Saved/Logs/EpicGamesLauncher.log” It should list your CPU and whichever GPU it’s using near the top. Did you ever find a fix? I think we need to somehow make the EGS prepend game launch commands with prime-run, or something similar.