Back to the main site

256 Error installing Linux game from GOG

Hey, I’m a n00b, go easy.

I have a Steam Deck. I am using Lutris and GOG. Windows games will install fine. I’m trying to install Mother Russia Bleeds, which is Linux and am getting:

Monitored process exited.
Initial process has exited (return code: 256)
All processes have quit
Exit with return code 256

at the end, but prior to that, no errors. However, if I navigate to the install and run start.sh, the game runs. But it will not run through Lutris. I get:

“This game has no executable set. The install process didn’t finish properly.”

Also, I just downloaded the installer from GOG, installed it, and again, it’s all good. I tried to add it to Lutris and when I run it, I get that same error.

Like I said, I’m new to this. I was trying to run in debug mode, but couldn’t figure out how to launch that. I’m just a mess, lol. Anyway, thanks in advance for any thoughts or help anyone has.

1 Like

Hey, well if your game runs with its start.sh script, point the game’s “Executable” field to the script.

Go to Configure for the game and on the Game Options tab, that’s where you’ll find the paths you need to configure.

1 Like

I have the exact same thing with another native Linux game here: Planescape Torment installation aborts with return code 256

It seems that some Linux game installers from GOG just exit normally with return code 256 and lutris just doesn’t handle them as successful installs.

1 Like

Thank you both. That took care of it. I’ll just save that for future knowledge how to fix it if I run into it again.

1 Like