0-1 fps [solved]

Thank you in advance to all reading. I’m not a linux guru, but I’m not incompetent either. I have had this problem in the ancient past, and always gave up. I’m a little more stubborn this time.

So I followed lutris to a T to install battle net launcher and then for reasons of testing, starcraft 2. The game installed flawlessly, and launches without a hitch. /rejoyce/ …then I try clicking around some menus, and it works fine except the framerate is literally less than 1. I’m getting maybe 1 frame every 2-3 seconds. Ok let’s try turning game settings down, turned it to windowed mode, all lowest settings and maybe 640x480 size window. Still 0-1 fps.

Also yes, I followed https://www.gloriouseggroll.tv/how-to-get-out-of-wine-dependency-hell/ so all those library’s are installed.

HARDWARE: x58 platform
I7-960 @ 4C/8T @ 4.1 Ghz
Gigabyte P6x58d mobo
12 GB ram 1600MHz
1070TI MSI Titanium
OS: Arch linux

I do have xinerama running, installed nvidia driver and nvidia-settings all seems to be good there. Currently working on xfce4 DE.

Any ideas? I will be at work until later tonight, but would LOVE to solve this problem!

UPDATE:: for some reason i am not allowed to reply on the forum? account under review… but anyway Dox - THANK YOU! it was actually the install method… i reinstalled using the Starcraft 2 installer, instead of the battle.net launcer one, and i’m getting 30 FPS… i think 30 FPS is a bottleneck with wine, more than the game. but it’s playable.

What version of Wine are you using with it?

See: https://appdb.winehq.org/objectManager.php?sClass=version&iId=20882

Edit: also, it’s spelled “xinerama”.

With your hardware, you should have no issues. So something is going on. I’ll ask some questions.

  1. Did you install with the Starcraft II installer? or did you use the standalone Blizzard App installer? (You should have use the SCII installer, but even with Blizzard App installer prefix you should get more then 1 fps)

  2. Do you have compositing enabled in XFCE? XFCE compositor is actually bad for gaming (or in general). Turn it off and test it if you have.,

[mrosebro@archlinux ~]$ wine --version
wine-3.4 (Staging)
[mrosebro@archlinux ~]$

30 fps is a start, you should be able to go higher (depending on what you play in SCII).

What screen size monitor or monitors are you using?

Why do you have Xinerama running? Do you have some weird screensetup with multiple X servers?

Yea 3x1080 + a 4th monitor above. I’m sure it’s just some settings to play with been having more luck.

If it over multiple video cards, you might need to tweak a bit. If it is 1 video card with 4 ports (like I have with Nvidia), you could turn off Xinerama altogether. Nvidia has a built-in Xinerama that will function just fine.

If you have multiple cards, you may need to look at some OpenGL settings. I did read something about it not long ago while I was browsing NVidia Readme, but can’t remember what it was.

Getting 1fps on a 1070 + i7 is totally not normal. Do native run ok and do games run properly without lutris?

native games fly like a DC-10, and without lutris things are bad… i managed to get most games running around 30-45 mark. I’m calling this topic solved, i appreciate everyone’s responces :slight_smile: