Back to the main site

World of Tanks missing wotlauncher.exe [solved]

Hi,

I tried different version of world of tanks installer but each time I a the same error :

the file ~/Games/worlf-of-tanks/drive_c/Games/World_of_Tanks/WoTLauncher.exe could not be found"

the web launcher file is correctly downloaded
then the installer show quickly “installation finished!”

i checked the files, wine prefix is created, but there is not a Games/World_of_Tanks created

any clues for me ?

regards,

Fixing. Should be up in a couple.

Edit: Ready.

I saw you modified all launchers for WoT ^^
But i tried each installer and i got the same error

the file ~/Games/worlf-of-tanks/drive_c/Games/World_of_Tanks/WoTLauncher.exe could not be found"

for the context :
I fixed my IP in EU
I use a fresh debian stretch x86_64
graphical card : geforce GTX 960 (nvidia driver v375.82)
I have lutris 0.4.18

  • for EU DXVK
    the launcher is downloaded
    the prefix is created
    no "Games/World_of_Tank created

  • for EU (wine)
    the launcher is downloaded
    the prefix is created
    no “Games/World_of_Tank” directory is created

  • NA DXVK
    the launcher is downloaded
    the prefix is created
    no “Games/World_of_Tank” directory is created

  • NA (wine)
    the launcher is downloaded
    the prefix is created
    no “Games/World_of_Tank” directory is created

  • asia (wine)
    nothing is installed
    ( i check manually and the url show an 404 error )

  • RU DXVK
    the launcher is downloaded
    the prefix is created
    no “Games/World_of_Tank” directory is created

  • RU (wine)
    the launcher is downloaded
    the prefix is created
    the installation is stuck when reading the file “drive_c/Games/World_of_Tanks/WoTLauncher.cfg” ( no "Games/World_of_Tanks is created

why the options “Game/View last game log” it say me “no game log available” each time ?:frowning:

i tried to take somes screenshots during the installation

for the no DXKV version I got :

err:module:load_builtin_dll failed to load .so lib for builtin L"msxml3.dll" : libxml2.so.2

for the DXKV version i got

err:module:load_builtin_dll failed to loade .so lib for builtin L"winex11.drv" : libX11.so.6

something related x386 headers ?

ok after some tests, I suppose I had a problem with my debian, because with :

apt --add-architecture i386
apt update

the last command didn’t update the headers for i386 architecture
despite the fact than :

dpkg --foreigner-architecture

return

i386

so … I reinstalled debian, and before the first command I type was “apt --add-architecture i386” and this time headers for i386 were installed

next I installed WoT with lutris, and this time the “Games/World_of_Tanks” directory is correctly created ( exepted for asia of course ).

And now when I launch the game, nothing is shown, only a “Game has quit” and nothing in the log.
If I try to launch manually an “exe inside wine prefix” the same thing append

@cxf
when you updated the launcher did you test than prefix architecture and wine staging 3.10-x86_64 were correct ?

regards,

edit:
Ok I solved my problem, after a long research, I notice user often have a problem with dependancies used by winehq.

By the past i tried playonlinux, and had often problem with missing or corrupted dependencies ( winetricks, wine). It was solved by installing from the orignals sources ( because playonlinux used old versions of dependencies and not regulary updated ).

For lutris there is the same problem.

wine ( stable and staging) must be installed from the original source you keep library up to date with the OS
the new versions can be downloaded trough lutris off course.

from a fresh debian stretch installed :

–add-architecture i386
wget -q -O - wget https://dl.winehq.org/wine-builds/Release.key | apt-key add -
echo ‘wget -q -O - wget https://dl.winehq.org/wine-builds/Release.key | apt-key add -’ > /etc/apt/source.list
apt update
apt install winehq-staging

source for others OS : wine dependency

next World of Tanks can be installed
( i tried EU DXKS and NA DXKS ; 5Gio is huge for me :x )