Back to the main site

WarCraft III Reforged - last patch broke it, anyone been able to fix it?

Hi all,

Been playing Warcraft III Reforged beta for a while and been working really well via Lutris. They released an update today (on 4GB!) that broke it. I can still launch Battle.net app without any issues but when launching Reforged it just crashes after showing a black screen for a few seconds.

The log files in Lutris (for the game) here.

Any tips?

System: Ryzen 3600, 32GB ram, GFX1650, POP_OS 19.10 - latest nVidia driver and updates in general.

I am having the same issue.

I had a look through my own wine logs, but I hit a dead end. I did find a few log files inside the windows file pathing. Dumps from dxgi and d3d11. The big error I saw there was in the log from ~/Games/world-of-warcraft-classic/drive_c/Program Files (x86)/Warcraft III Beta/Warcraft\ III_d3d11.log:

err:   DxgiSwapChain::GetFrameLatencyWaitableObject: Not implemented
err:   DxgiSwapChain::SetMaximumFrameLatency: Not implemented

This to me indicates an issue with DXVK, but I don’t have any more time tonight to dig into it. I think in the morning I’ll try overriding the dxgi / d3d11 libraries in wine. Maybe start there?

My system: nVidia 1080Ti, 16GB Ram, Manjaro 16, latest nVidia non-free. I also have WC3 Rf installed using my WoW Classic Lutris config right now, because it felt weird to have 2 battle net launchers? So maybe that contributes, but IDK. WoW Classic still works.

1 Like

Even though I’m not using Lutris, I’m experiencing the exact same issue as the both of you. I’ve tried adding -graphicsapi OpenGL to see whether it would launch with OpenGL, but it still crashes, so I’m not sure whether it’s related to D3D being the problem, though I’m also not sure whether OpenGL is supported in the beta, but it’s definitely not working as of the last patch with wine-staging-4.20, while it was basically gold before (using DXVK).

P.S.: Using wine-staging-4.20 with the latest 440 series NVIDIA driver release on Gentoo Linux.

UPDATE: I’ve also tried playing with: -windowmode fullscreen, but no luck so far. This is the big patch where they’ve added Night Elves, so I guess it has something to do with the major changes in the game.

1 Like

The problem has been fixed in dxvk 1.4.6 released today. Just upgrade and it’ll work again. They’ve implemented the missing dxgi features. See: https://github.com/doitsujin/dxvk/releases/tag/v1.4.6 for details.