Back to the main site

Stuttering Battlefield 1

Good morning, everyone,
I have an I5 with GTX 1060 6GB.
I want to play Battlefield 1. The problem is that I have a lot of stuttering. It hurts my head.
I put Battlefield 1 on SSD as requested.
I use Wine 3.21 with DXVK 1.2.3.
Can you give me the config to put in lutris to remove this annoying problem.
Thank you in advance.
Have a good day, everyone.

Try ge-protonified-4.10-x86_64 Wine version, enable DXVK and try Esync on or off in Lutris game configs. I have Esync off atm.

“You can download different wine versions to Lutris from left panel Runners -> Wine -> Manage versions. Then configure your game to use it.”

Turn in-game graphics settings to lowest possible and limit fps to 60, when you got stable experience with no stuttering start increasing graphics settings to see where you get nicest graphics with good performance. You should get stable 60 fps in about medium settings.

What distro and desktop you use?

Thanks.
I use Ubuntu 18.04.2.
I test with Wine 4.xx and it crashes.
I’ve already put the graphic details in low.

I have a nvidia 1060 card.
If I took an AMD RX 580 card, would it be more fluid? I have a big doubt about the quality of Nvidia drivers on Linux.
Thank you in advance.

I have RX 470 and I5-9600K, stable 60 fps in BF1 and BFV low or low/med settings 1080p. So 580 would perform even better.

You could also try GameMode -> https://github.com/FeralInteractive/gamemode
It should start automatically when you launch game from Lutris if installed.

Other than that can’t say anything else cause don’t have experience from nvidia cards on linux… One issue might be Ubuntu 18 and it’s old software. I was a year on a Linux Mint that is based on that Ubuntu 18. Didn’t even get origin to launch and had issues on other games and softwares. Installed Manjaro Cinnamon about six months ago and problems went away. I would highly suggest Manjaro for gamers, newer software and kernel just helps a lot.

Thank you.
I already use gamemode and libstrangle.

I will try to install dxvk by hand. We’ll see after that.

I finally made it.
I activated Wayland and it works fine.
It’s as smooth as Windows.