[SSL: certificate] error specifying an action (when downloading runners & trying to login)

Hello everyone!

A few days ago my PC randomly died – because I broke something software related and it was just too much of a hassle to fix it I ended up freshly installing my main OS completely (Linux Mint 19 Tara).

Here is the output of uname -a:
Linux xx-0x-linuxmint 4.18.7-041807-generic #201809090930 SMP Sun Sep 9 09:33:16 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

No runners in Lutris work giving the following output when I try to configure/install them:
"*" not available on the x86_64 architecture

Lutris used to work fine and even survived the update from Linux Mint 18.3 through the process in the Update Manager and now it just won’t work.

Should I report this as a bug or is this something fixable and just a quirky issue on my side of things?



Error persists with kernel update 4.18.8. Does anyone have any idea what to do? Also login in the client does not appear to work.
Anyone anything to add?

Anyone any tips?

Did you try reinstalling Lutris? Do you have backups? Does it work on such backups?

Do you have python updated? Are you particulary trying to run Wine? If so, do you have winehq-staging with recommended packages installed?

The kernel itself should influence this, only your packages and the configuration of your APTitude package manager.

The only thing I can look “strangely” right now is how X86_64 has that capital X in front, instead of the regular x86_64 form. But you could have written that yourself.

Please give particular runners and attempt processes to see if people can help you out. Also, starting lutris in a terminal with

lutris -d

may help you with debug messages.

1 Like

sounds like a wine message, install whatever version of wine is available in Linux Mint this will pull in all dependencies.

Hello guys!
First of all thanks. I feel like I am losing my mind here. :wink:
Just to reiterate: logging in client does not work, as well as installing runners and using scripts.
I am running Linux Mint 19. Used to work fine under 18.3. No backups due to hard drive failure — reason I had to reinstall in the first place. Issue seems to be regardless of runner I have tried basically all of them just to be sure.
System version of Wine works fine. And should be installed from winehq.org repo wine-staging so that should not be the issue.

How do I update python the best way? It should be up-to-date but maybe there is a better repo etc.?

Other things I have tried: using just about any .deb file I could find to install Lutris instead of installing from synaptic/terminal using apt / apt-get — no success.

@dan1lo_bc: The upper case x is indeed a mistake on my part. It is lower case in the error message.

lutris -d seems to get us somewhere. Wish I had known there was a debug mode before. :smiley:
Same issue every time. And it has basically nothing to do with the arch but with the “unavailable” part — but in my defense that error message sure was confusing. :smiley:
It apparently can’t connect to the server over a secure connection? Can I force a connection somehow?
Maybe tell it to not verify at all?

Output of lutris -d starting and trying to install runners:

ERROR 2018-09-26 16:30:10,741 [dxvk]:<urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:841)>
ERROR 2018-09-26 16:30:11,088 [http]:Unable to connect to server (https://lutris.net/api/runtime): <urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:841)>
DEBUG 2018-09-26 16:30:11,090 [api]:Fetching game library
DEBUG 2018-09-26 16:30:11,255 [steam]:Watching Steam folder /home/goldsteal/.local/share/Steam/steamapps
DEBUG 2018-09-26 16:30:44,205 [runner]:Installing libretro (version=None, downloader=None, callback=<function libretro.install..install_core at 0x7f01077da7b8>)
INFO 2018-09-26 16:30:44,205 [runner]:Getting runner information for libretro
ERROR 2018-09-26 16:30:45,288 [http]:Unable to connect to server (https://lutris.net/api/runners/libretro): <urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:841)>
DEBUG 2018-09-26 16:31:01,827 [runner]:Installing higan (version=None, downloader=None, callback=None)
INFO 2018-09-26 16:31:01,827 [runner]:Getting runner information for higan
ERROR 2018-09-26 16:31:01,879 [http]:Unable to connect to server (https://lutris.net/api/runners/higan): <urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:841)>
DEBUG 2018-09-26 16:31:07,308 [runner]:Installing dolphin (version=None, downloader=None, callback=None)
INFO 2018-09-26 16:31:07,308 [runner]:Getting runner information for dolphin
ERROR 2018-09-26 16:31:07,361 [http]:Unable to connect to server (https://lutris.net/api/runners/dolphin): <urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:841)>
DEBUG 2018-09-26 16:31:10,676 [runner]:Installing ags (version=None, downloader=None, callback=None)
INFO 2018-09-26 16:31:10,676 [runner]:Getting runner information for ags
ERROR 2018-09-26 16:31:10,729 [http]:Unable to connect to server (https://lutris.net/api/runners/ags): <urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:841)>

It also appears to be the same issue as in this post or at least closely related to it: I can't login lutris app

So what to do from here on? Suggestions?

Greetings and thank you all so much


Before we proceed, can you say your python versions? Type in a terminal

python --version

and then

python3 --version

You’re probably somehow running a specific python version that is not OK with Lutris. Also, try to minimize the use of .deb packages. Use apt install for all the packages you can (similar to using the Software Manager GUI), also try to never use synaptic, since it forces installation and uninstallation of packages in a slightly different way. This includes your Python installation.

1 Like

I did not know that about synaptic. Will keep that in mind. Usually I only use .debs if there is no other option. This was just for testing purposes. At least Lutris should be entirely the PPA provided by the website.
To your question:

python --version

Python 2.7.15rc1

python3 --version

Python 3.6.6



You have the same Python versions I’m running, so it’s probably not a fault of your general setup.

I’m under Linux Mint 19 as well on kernel 4.17.19, updated via Ukuu (adding a PPA, etc etc). I had to get this kernel version because I’m on Ryzen 2400G and it crashes otherwise. Other than this small variation, we are under the same base system, so error shouldn’t happen.

I just tried installing libretro and the downloaded began right away. I think you can’t go through this step, right?

I suggested changing the thread name to simply [SSL: certificate] error specifying an action (when downloading runners).

At this point, maybe you’re better asking directly at github, similar to this thread.

The only suggestion there is that it should be a server/site hiccup, but if you still can’t access things over there after a couple days and tries, something should be wrong.

I’m pretty sure you’re able to access other HTTPS sites with no problems, anyway.

Exactly trying to install any runner gives me the error.

Yeah, it’s been weeks now. Oh, well. We’ll get there eventually :wink:

Will adhere to your suggestion and change the title as fast as possible.

Greetings from Germany


There’s a problem with the new Cloudflare configuration and the certificates that have been setup. I am not able to reproduce this issue and would need more information to be able to investigate.

For anyone with this issue can you give me:

  • your linux distribution
  • the version of libssl installed on your system
  • your geographical location (country or region is enough)
  • the ip address you get when pinging lutris.net
1 Like

Just tried on 2 machines, 2 different networks, and I’m ok on the login page and the app, but the wiki page fails outright on both:

Ubuntu 18.04 machine
OpenSSL 1.1.0g 2 Nov 2017

OSX machine (no app for obvious reasons)
libressl 2.2.7

IPs (same on both)
ping www_lutris_net =
ping wiki_lutris_net =
[ _'s just to bypass the link-matching thing]

actual message:
Error 526
Ray ID: 46795b4ded1d91a0 • 2018-10-10 13:15:36 UTC
Invalid SSL certificate

[EDIT cutting out the “if you’re the end-user, try again” part]

If you’re the owner of this website:

The SSL certificate presented by the server did not pass validation. This could indicate an expired SSL certificate or a certificate that does not include the requested domain name. Please contact your hosting provider to ensure that an up-to-date and valid SSL certificate issued by a Certificate Authority is configured for this domain name on the origin server.
[extra info link goes here: https://support.cloudflare.com/hc/en-us/articles/200721975 ]

The wiki page was taken down in favor of github. https://github.com/lutris/lutris/wiki

HAH!..DERP DERP :blush:

yeah, I tried setting up a redirection on Cloudflare for wiki.lutris.net but that didn’t work.

I know that there are some issues with other sub-domains but I want to focus on lutris.net only for now, since it’s behind CloudFlare and should work for everyone.

1 Like

I have about zero knowledge on the subject, but would using some type of VPN interfere with SSL certificates?

I know it’s so common for people to use them nowadays they quickly rule them out as possible causes for errors.

I’m still waiting for someone with the actual issue to come back to this, everyone has gone mysteriously silent after I started asking for info.

1 Like

I am definitely not mysteriously gone. :smiley: Not exactly sure what I can give you that has not been mentioned beforehand though.

  • linux distribution: Linux Mint 19 Tara (w kernel 4.18.14-041814-generic)
  • libssl: 1.1.0g-2ubuntu4.1
  • geographical location: Europe/Germany
  • the ip address when pinging lutris.net: 2606:4700:30::681b:baf5
  • the ip address when pinging www.lutris.net:
  • the ip address when pinging wiki.lutris.net: 2606:4700:30::681b:baf5

2606:4700:30::681b:baf5 seems to be the one creating issues? Visiting wiki.lutris.net in a browser gives me a cloudflare error:

Error 526 Ray ID: 4699aab9c9646391 • 2018-10-14 11:22:13 UTC ## Invalid SSL certificate

I have an active issue on Github , updating it constanly. I’m neither using VPN or anything like that also.

I’m not anywhere near silent :smiley:

@Leopard: I have also opened a bug report a while ago – can we merge those somehow?