[SOLVED] FFXIV Doesn't work in DX11 mode

Did you try following these steps on APPDB in the Workaround section? https://appdb.winehq.org/objectManager.php?sClass=version&iId=35777

Yes, I did. Actually, the lutris installer already does this.

Eventually, I tried other builds of wine and proton, I actually got it to work now.
I used ge-protonified-4.9 and got it to run and play!

Not sure why, but ge-protonified-4.10 doesn’t work but ge-protonified-4.9 does.
Other builds that didn’t work was lutris-experimental-4.10, ge-protonified-4.10 and 4.8 (all of these resulted into immediate crash), tkg-protonified-4.6, tkg-ffxiv-4.6 and tkg-feffe-ffxiv-4.6 (all of these resulted into DX11 crash)

Problem has been solved now. I just hope ge-protonified-4.11 solves this when I update launchers.

Solution: Use ge-protonified-4.9 instead of 4.10

1 Like

Wow! I’m so glad you solved it!

Sometimes updates bring regressions. If you check some Valve Proton patch notes, it happens every once in a while (and they’re usually patched right after). It does require them some time to check for bug reports in their vast library of games.

All in all, stick to a version that works, experiment something new to see if the regression was solved, if not, fall back.


1 Like

Thanks soo much for the support and help! Couldn’t have figured it out if I wasn’t pointed to places where I wouldn’t check.

Thanks again!