[Solved] Can't install anything

I’m really new to linux but I think I’m managing quite well so far, but I just can’t really make anything work on litrus for some reason. Every time I try to install something it throws some exceptions that I can’t even find a discussion about and I’m stuck.

So far I’ve tried:

  • Manually installing Wine Dependencies
  • Changing Wine Versions
  • Manually installing the game through Lutris instead of the auto install

I mostly tried to install League of Legends, but errors happen with other installations too, but with different codes, but mostly the same error message in log. wine: could not load kernel32.dll

League Error Log
Rocket League Error Log

I’m using POP_OS 21.04

I would really like some help with this because I just can’t find anything that would help for more than 2 days at this point!

Edit: It was my CPU, it was just really old and so it wasn’t compatible with how lutris works

1 Like

“wine: could not load kernel32.dll, status c0000135”

This has to do with the wine prefix (for each game a specific prefix is created). Did the install complete?

I advice you to use the install script from lutris.net as it contains al switches for the games to work. Also read trough any issues from other users. Especially with LoL the list is quite long.

And make sure the old game data is deleted so Lutris can start a fresh install.

@Citrom I’m getting very similar exceptions (see other thread) and I suspect lutris wine version to use a CPU feature which my old CPU (Core 2 Quad Q9650) doesn’t support. What CPU does your machine use?
My workaround is to use an older wine version in lutris, lutris-6.1-3 seems to work on my machine.

@counthope Thank you ! This workaround works for my Core 2 Duo T9600 CPU. The latest versions of lutris wine didn’t work for me. So I think I have the same problem than you because of this old CPU.

I have also noticed that my CPU is used at 100% in a 2003 game (without lagging), but it may be not related to the “kernel32.dll” problem.

I would be glad if this problem could be solved in further updates.

No, the install doesn’t complete after these error messages.

I tried alternative install scripts, but didn’t help much… tho one helped me install the launcher, but didn’t work after that, which I assume doesn’t count in this issue since it has separate issue posts

But I also tried different wine versions as in the other reply has suggested, but nothing changed.

Also tried to install through PlayOnLinux in both from the installer that it downloads, and with the installer that I downloaded, but it fails there too so it’s definitely something up with wine or winetricks