Seeking a bit of help for Path of Exile


After a while, I decided to try again PoE DXVK with lutris. Long story short, once again I can’t manage to make it run.

But, since I’m not using Steam, this install script (the most recent currently)

Right now: the game start, resize my display resolution, goes to black then quit.

And sadly the console only throw errors about fonts. (Those, I can painstakingly get through them, if I find where to find them)

Until I start the game through console itself (rather than through Lutris) with

wine path/to/exe --waitforpreload --nologo --nodx9ex --gc2

So I’ve no idea what is going on. Am I stupid? am I only missing something? I guess the problem is me (or rather some lib I didn’t got), but I can’t be sure.

I’ve been playing Path of Exile on linux recently but I gave up because of the clunkiness to get it to work. I was good with a dx9 version, but then in the Incursion league update, the light around the character stopped appearing. The game would be pretty dark without it.

Going to the dx11 version fixed lighting, but the game suttered a lot loading shaders. I usedthis hack to get the game working again and it works extremely well and smooth.

However, I changed hardware from geforce 740m to using Ryzen’s 2400G integrated gpu (APU).

Since the change, I’ve been struggling to get things going back around… So let me share the knowledge I obtained so far.

  • Please remember to use WINEPREFIX=yourpath before issuing the start command. The wine path/to/exe you posted lacks that bit of information. Also remember you may have a completely differente wine version than Lutris uses.
  • The DX9 version seems to work with fewer mistakes than any other version, however it feels slightly less optimized
  • The DX9Ex version, in some machines, is recommended to play more fluidly
  • To play the DX11 version, you need a patch to get rid of all those missing font crash dialogues. The main Wine version to have those patches is I’m not sure this means the same as “wine with PBA patches”, please check. That version of wine has a bugfix implemented that somehow never made it to the main branch of wine.
  • Lutris has a ge-wine 3.6 available for DX11 compatibility. It worked until recently, when I got some error about Textured3d11
  • To test wine-escync, please remember to follow additional steps:

My recommendation of troubleshooting right now is:

  1. Install the standalone Lutris script
  2. Either try running with esync-3.13 or staging-3.13
  • esync may help performance with the dx9 version (not tested!)
  1. When picking the executable for Lutris, consider PathOfExile.exe and the x64 equivalent. Remember the 64 bit version may only work with patched Wines
  2. If your game crashes on startup, consider going into the production_config.ini (I think that’s the name of the settings file for PoE) in your My Documents>My Games> Path of Exile (or similar) folder, in your wineprefix, and change the dx11 key to dx9.

As far as I know, any variation of versions should patch the game correctly, but actually playing the game requires knowing what directx version to pick and what “.exe” file.

p.s.: That said, I’ll try running the latest PoE script and see if it runs “as is” on my machine. PoE or Wine updates have fixed things. Currently patching.

Yes, I just did a fresh install of Path of Exile and nothing worked.

escync-3.13 seems promising but freezes after a few seconds. Regular staging crashes left and right. ge-wine doesn’t work for DX11 over here anymore, maybe it needs some winetricks or overrides.

The install script makes it feel really easy how to play this game, but both my testing and APPDB people confirm it’s painful.

Since this thread has been quite popular in views, I wanted to point out my post in another thread suggesting an alternative way to get things to work if the default DX9 or DX11 solutions don’t work right away.