Back to the main site

[REPOST] Epic Games Store not working

This post was flagged by the community and is temporarily hidden.

  1. X Error of failed request: GLXBadContext

  2. Major opcode of failed request: 155 (GLX)

  3. Minor opcode of failed request: 6 (X_GLXIsDirect)

  4. Serial number of failed request: 251

  5. Current serial number in output stream: 250

Looks like driver error.Can you post output of glxinfo?Have you tried updating/ reinstalling gpu drivers?

glxinfo output: https://paste bin.com/raw/gS1RT897 (space because it won’t let me post links)
As for updating/reinstalling GPU drivers, I don’t really know how to do those.

Did you install epic game store from here https://lutris.net/games/epic-games-store/ ?
You could try changing wine version in lutris.
Do you have wine installed systemwide(for dependencies)?
You could try running sudo apt-get install --reinstall libdrm-intel1 xserver-xorg-video-intel libgl1-mesa-glx

  1. Yes
  2. Tried all the versions I had installed, most of them were non-esync compatible or didn’t work
  3. Yes
  4. I tried that but nothing changed

Could you try disabling dxvk and prefer system libraries option in lutris? You could try check if anything helps from here Epic Games Store not starting
Also from comments https://lutris.net/games/epic-games-store/ I can see that other people are also having problems with epic game store lately.

I already checked that page before and tried disabling prefer system libraries and dxvk. I also attempted to change the compatiablity to windows 7 as one of the comments on the lutris epic games section. But none worked.