Back to the main site

Phoenix Point - Frozen start screen

This post was flagged by the community and is temporarily hidden.

I don’t have this game but when you start lutris from a terminal with the following command you should be able to see some logging.

lutris -d

This post was flagged by the community and is temporarily hidden.

Ah! A limit on the maximum files which can be opened.

Follow the instructions on this page please.

It’s a message from ESync b.t.w.

…First step is to run the ulimit -Hn command. If the value printed is equal or greater to 524288 then you’re all set, your system is ready to use Esync! If you are running Systemd 240 or later, this should already be the case…

The ulimit -Hn should return a number larger than 524288.

This post was flagged by the community and is temporarily hidden.

And that number is too low.

Time for the next step in the document. There are two methods depending on your distro having systemd. If you don’t have the files /etc/systemd/system.conf or /etc/systemd/user.conf then you probably need to use method two.

Modifying Systemd configuration
This method applies to Ubuntu and other systems using systemd (some systemd distros can also use the limits.conf method below). You (with root privileges or sudo ) need to edit both /etc/systemd/system.conf and /etc/systemd/user.conf by adding DefaultLimitNOFILE=524288 . If DefaultLimitNOFILE= already exist in both system.conf and user.conf , add 524288 after = and make sure to uncomment the line (remove the # ) to make it functional.

Once the files are edited, restart your computer for the changes to take effect. To verify if the limits were applied, run ulimit -Hn to see open files limit (it should report 524288 ).

If the value printed still says something like 4096, try the ulimits method below.*

So open up a terminal en type:

sudo nano /etc/systemd/system.conf

Add (or change) this entry: DefaultLimitNOFILE=524288

Then CTRL+X + Y and <enter> to accept the changes.

Then…

sudo nano /etc/systemd/user.conf

Add (or change) this entry: DefaultLimitNOFILE=524288

Then CTRL+X + Y and <enter> to accept the changes.

I had both files and I have edit it. Then I got 524288 with ulimit -Hn.
I had started lutris and epic and the game. But the picture is frozen on the same point. In the background is the gamemusic on. And the fog behind “Online guidelines, agreements…" is moving. I can move the mouse. But I can not agree or disagree. The same problem.

No more log entries?

My setting is 1048576 btw.

edit: you could also try disabling esync for this game.

This post was flagged by the community and is temporarily hidden.

I have checked the files, which I’ve modified. The result is 524288, in terminal.

I don’t see any messages regarding esync so that one is fixed.

The Unable to read stat for process message I got earlier with another game. The solution there was to change out a winetrick.

Looking at at this log and the installer script I would focus at dxvk.

This guy has made a tutorial which follows the same logic as the installer script does. He also mentions the versions used.

  • Wine version used in the video: Wine-Staging 4.21 with ESync enabled.
  • DXVK version: 1.4.6

Both can be selected in Lutris. I would start there.

Side note: I also see this message: Wine cannot find the FreeType font library. To enable Wine to
use TrueType fonts please install a version of FreeType greater than or equal to 2.0.5.
This should be in your software repositories.

I’ve install the FreeType front library (I think) and the TrueType fonts. (I think).

I’ve downloaded the mf-install-master-folder.
Than I’ve found the folder pfx.
And what I’ve to do now? (I do not understand the readme-file)

The installer script also has the mf-install procedure so don’t focus on that. Focus on the Wine version used, Esync enabled and DXVK.

When you go into the settings of the game in Lutris and then the Runner options you will see those settings. Try to mimick these versions:

  • Wine version used in the video: Wine-Staging 4.21 with ESync enabled.
  • DXVK version: 1.4.6
  • Esync on

This post was flagged by the community and is temporarily hidden.

I see DXVK activated in your screenshot.

There is a different problem. See the log you posted:

ERROR 2020-03-24 07:24:34,989 [startup.check_libs:112]:i386 libvulkan.so.1 missing (needed by vulkan)
INFO 2020-03-24 07:24:34,994 [startup.check_vulkan:134]:Vulkan is not available or your system isn’t Vulkan capable

DXVK is a translator from DirectX to Vulkan.

You seem to be missing the 32 libvulkan library. What distro are you using?

If I acitivate DXVK, save it, close the options and start the options, DXVK ist not activate.

operating system: LinuxMint Cinnamon 19.3 (64 bit)
CPU: AMD Ryzen 2700X
RAM: 16GB
Graphiccard: Radeon RX Vega 56

How I can Vulkan install?

But I can play XCOM2 and other games.

Yes. Most probably because Vulkan isn’t active.

See the following link. The command to install libvulkan is there too.


AMD / Intel:

If you have Ubuntu 19.10 or newer: Enable 32 bit architecture (if you haven’t already):

sudo dpkg --add-architecture i386 

Install support for 32-bit games:

sudo apt install libgl1-mesa-dri:i386

Install support for Vulkan API (will be functional only if you have a Vulkan capable GPU):

sudo apt install mesa-vulkan-drivers mesa-vulkan-drivers:i386

Reboot to apply changes.


I did it, but no change.

It’s strange, but in my driver management is no driver. It’s okay?

Do you have a new log file? That’s the way to be really sure the situation is the same.