Back to the main site

Lutris stuck updating d9vk

That’s it. The lutris window doesn’t appear. Below is the output of the console.

INFO     2020-03-15 17:06:00,346 [application.do_command_line:225]:Running Lutris 0.5.4
INFO     2020-03-15 17:06:00,347 [startup.check_driver:62]:Using X.Org
INFO     2020-03-15 17:06:00,347 [startup.check_driver:67]:Running Mesa driver 19.3.3 on Radeon RX 580 Series (POLARIS10, DRM 3.35.0, 5.4.0-4-amd64, LLVM 9.0.1) (0x67df)
INFO     2020-03-15 17:06:00,347 [startup.check_driver:79]:GPU: 1002:67DF 1462:8A92 using amdgpu drivers
INFO     2020-03-15 17:06:00,347 [startup.check_driver:79]:GPU: 1002:67DF 1462:8A92 using amdgpu drivers
INFO     2020-03-15 17:06:00,399 [startup.check_vulkan:132]:Vulkan is supported
INFO     2020-03-15 17:06:00,400 [dxvk.get_dxvk_versions:21]:Updating DXVK versions
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/lutris/gui/application.py", line 173, in do_activate
    self.window = LutrisWindow(application=self)
  File "/usr/lib/python3/dist-packages/lutris/gui/lutriswindow.py", line 102, in __init__
    self.game_store = self.get_store()
  File "/usr/lib/python3/dist-packages/lutris/gui/lutriswindow.py", line 321, in get_store
    self.show_installed_first,
  File "/usr/lib/python3/dist-packages/lutris/gui/views/store.py", line 133, in __init__
    self.modelsort = Gtk.TreeModelSort.sort_new_with_model(self.modelfilter)
AttributeError: type object 'TreeModelSort' has no attribute 'sort_new_with_model'
INFO     2020-03-15 17:06:00,849 [dxvk.get_dxvk_versions:21]:Updating D9VK versions

Link removed because the issue has been reported.

This issue has been reported. It has to do with an updated Gtk version.

Thank you, I’ll just wait for an update then. I figured it was something like that. I thought maybe a python update, as that has messed things up for me on occasion. I do not like being on Debian testing, no I do not. I look forward to the day when bullseye becomes stable. testing is a pita…

I had the opposite issue (my newest version of GTK has sort_new_with_model but doesn’t have new_with_model which my current version of Lutris tries to use). I temporarily (until next release) fixed it by backing up the gui/views/store.py file in the Lutris install (i.e. making a copy with ~ appended to filename) and changing the name of the function in the original file to the one that works on my system (it only occurs once, on line #133).

1 Like

Dude, you’re brilliant. Thank you so much.

Note that after trying LeX’s solution I had to disable esync to get wine games to run.