Back to the main site

Lutris not detecting Steam ProtonGE versions

Lutris will not recognise my Steam Proton versions, where I have Proton-GE versions installed.

I don’t want to link each and every version of Proton-GE, is there a way to ensure that Lutris automatically detects these?


1 Like

What are you talking about? Are we talking about steam Proton or wine Proton? I’m sure that lutris don’t support steam Proton i haven’t tried, but it’s not on the download option, so my bet it wouldn’t be.

Download protonup-qt there. You can download all support Wine-environment for lutris, even Wine-GE.

I’m primarily active on
Installing Games on Linux.

I used to be able to see my Steam Proton versions in Lutris, so this is supposed to work. Don’t see why we should download ProtonGE twice each time.

if you haven’t try this

1 Like

Symlinking folder manually is an error waiting to happen. Lutris used to detect these Steam Proton versions. Now it doesn’t, I’m trying to find out if there’s a real solution.

Using symbolic links as a matter of course IS an error waiting to happen. I’ve seen Linus Torvalds say that, even.

Get a load of what the distros are doing now, if you think creating a few symlinks to Proton is bad. They call it “usrmerge” where /bin and /lib and friends are symlinks to /usr/bin,lib etc. Some of them have even done away with libexec and even sbin and those are symlinks to /usr/bin as well.

Break that symlink and the kernel won’t find init.

I mostly just download wine-proton with proton-qt and they work as good as proton on steam from the few games I used it on like F.E.A.R

I always use the runners from gloriouseggroll. In steam i use the gloriouseggroll proton.

1 Like

Well… lately, I’m finding myself using Proton-GE for more and more games on Steam because Valve breaks games.

Not only that, they deliberately sabotage the microsoft mediafoundation dlls by enforcing symlinks to stubs every time the wine prefix is updated and it’s getting increasingly difficult to fix (the last time I tried to with Proton 6.3-8 they wouldn’t even work anymore), so I switched those games to Proton-GE. This especially plays Hell with Borderlands 3, which will not progress quest triggers if embedded video objects don’t play. Reverse engineered dlls from upstream wine will not do for this either, it has to be the real libraries extracted from cab (mf-installcab) for that game.

On Lutris I have used runners built by gloriouseggroll at times, but the Lutris runners have been very good for me. I’m currently using Lutris 6.21-6 for everything in Lutris, even EA Origin and the games are working nicely with that one. (Also using Lutris provided DXVK 1.9.2L-xxxx and vkd3d 2.5L-xxxx)

All of this shit, Proton-GE, Lutris wine runners (since Wine 6.x I would say) have surpassed Valve’s Proton in my opinion.

1 Like

I had so many problems with proton and how steam handle prefix that I gave up and now I just run steam inside wine. Works much better and then I use lutris to run and install steam games. It also makes it easier when you need to install NET, Vrun, WMP, and MF.

I do have a Windows Steam client installed in Lutris, but I’ll probably delete it because I’m not using it anymore. It runs like crap, with the canvas flashing in and out but if I time my hovers right I can use the UI. I just had it for some dumbass games that used the CEG DRM, but that’s in Proton now and those games work with Proton 6.3-8 for me.