Lutris 0.4.0 issues on Mint 17.3

Hello, I’ve been busy lately so I couldn’t test the latest git version but I just got the update and I tried to run in. The GUI didn’t show up, so I started it from the terminal to catch the output. This is it:

Traceback (most recent call last):
File “/usr/bin/lutris”, line 52, in
from lutris.util import service
File “/usr/lib/python3/dist-packages/lutris/util/”, line 3, in
from lutris.gui.lutriswindow import LutrisWindow
File “/usr/lib/python3/dist-packages/lutris/gui/”, line 30, in
from lutris.gui.flowbox import GameFlowBox
File “/usr/lib/python3/dist-packages/lutris/gui/”, line 65, in
class GameFlowBox(Gtk.FlowBox):
File “/usr/lib/python3/dist-packages/gi/”, line 320, in getattr
return getattr(self._introspection_module, name)
File “/usr/lib/python3/dist-packages/gi/”, line 139, in getattr, name))
AttributeError: ‘gi.repository.Gtk’ object has no attribute ‘FlowBox’


this should now be fixed in the latest update I’ve pushed. Lutris will now fallback to the list view if the version of Gtk doesn’t support FlowBox

There are still a few fixes I need to release so expect another update today.

Indeed, an update arrived as 0.4.0ubuntu3 and now the client starts properly. Thanks for your reply. :slight_smile:

Right after I start Lutris I get this:
WARNING 2016-10-18 01:32:19,135 [winesteam]:wine is not installed

Why wouldn’t Lutris try to work with the system’s wine by default? Of course, I installed Wine from “Manage runners” and restarted Lutris, and the warning went away.

Next, the connection issue is still a problem. This is what I get when I click connect in the menu:

Traceback (most recent call last):
File “/usr/lib/python3/dist-packages/lutris/gui/”, line 407, in on_connect
login_dialog = dialogs.ClientLoginDialog(self.window)
File “/usr/lib/python3/dist-packages/lutris/gui/”, line 249, in init
super(ClientLoginDialog, self).init(parent=parent)
File “/usr/lib/python3/dist-packages/lutris/gui/”, line 21, in init
gi._glib.GError: /usr/share/lutris/ui/dialog-lutris-login.ui:84:1 requires attribute “id”

And when I click the “runner types/categories” (Browser, Linux, Steam, Wine) in the left column I get these:

Traceback (most recent call last):
File “/usr/lib/python3/dist-packages/lutris/gui/”, line 747, in on_sidebar_changed
AttributeError: ‘GameListView’ object has no attribute ‘invalidate_filter’

Today’s next update will have a fix for the system’s wine version not being detected and the invalidate_filter issue.

The requires attribute “id” bug, I need to work on that (staring by reproducing it). I’ll give it a try on my Ubuntu 14.04 VM.

1 Like

The missing id parameter has now been fixed as well :slight_smile:

1 Like

a new build should now be available in the repos with all the fixes.

1 Like

OK, all the aforementioned messages are gone. I’ll look for more. :slight_smile:

I don’t know if these are temporary or not, but I got them:

ERROR 2016-10-18 02:30:37,320 [http]:Unable to connect to server ( <urlopen error [Errno 111] Connection refused>
INFO 2016-10-18 02:30:37,321 [lutriswindow]:Connected to as kneekoo
ERROR 2016-10-18 02:30:47,374 [http]:Unable to connect to server ( <urlopen error [Errno -2] Name or service not known>
ERROR 2016-10-18 02:30:52,425 [http]:Unable to connect to server ( <urlopen error [Errno -2] Name or service not known>
WARNING 2016-10-18 02:30:52,425 [resources]:Unable to get games from API

And a lot of these, for many games:

ERROR 2016-10-18 02:33:06,582 [http]:Unable to connect to server ( < urlopen error [ Errno 111] Connection refused>
ERROR 2016-10-18 02:33:06,582 [http]:Unable to connect to server ( < urlopen error [ Errno 111] Connection refused>
ERROR 2016-10-18 02:33:06,649 [http]:Unable to connect to server ( < urlopen error [ Errno 111] Connection refused>
ERROR 2016-10-18 02:33:11,760 [http]:Unable to connect to server ( < urlopen error [ Errno 111] Connection refused>

Possibly a rate limit issue of the web server? I have a lot of games in Steam and if the client pushed over 200 http requests at the same time I probably got a virtual smack over my head. :grin:

If this is the case (one http request per title), maybe group the games’ ids in a JSON structure and pass that to the API in a single request.

OK, now I tried to run a Steam (for Windows) game and Lutris told me I need to download a runner. I got these messages in the terminal:

ERROR 2016-10-18 02:43:06,929 [display]:Failed to retrive cursor “wait” for display “< gtk.gdk.X11Display object at 0x7f759f8353a8 (GdkX11Display at 0x1896060)>”
INFO 2016-10-18 02:43:19,624 [wine]:win32 Prefix created in /home/nicu/.local/share/lutris/runners/winesteam/prefix
ERROR 2016-10-18 02:43:20,020 [display]:Failed to retrive cursor “default” for display “< gtk.gdk.X11Display object at 0x7f759f8357e0 (GdkX11Display at 0x1896060)>”
ERROR 2016-10-18 02:43:20,322 [display]:Failed to retrive cursor “default” for display “< gtk.gdk.X11Display object at 0x7f759f835438 (GdkX11Display at 0x1896060)>”
The last two lines kept repeating until I closed Lutris.

Connections problems to the website can happen sometimes but it shouldn’t be something permanent. There is no rate limiting and potential issues are due to the hosting company (or something between their servers and you).

Yep, that’s exactly what we’re doing since 0.4.0 :smiley: but that’s only to retrieve the URLs of banners, then each banner has to be downloaded individually. We launch downloads in parallel so if you have connection issues, you’re likely to have a lot of error messages really fast :stuck_out_tongue:

The “Failed to retrieve cursor” errors can be safely ignored, it shouldn’t keep things from running. I’ll try to make things more quiet in those cases.

If you got permanent connection issues then that’s a bigger problem… Does the website load fine in a browser? (I guess it does since you’re able to post in the forums, which are on the same server)

I did have issues accessing the main domain ( It was temporary, but it didn’t load. The browser said the site is unavailable or something like that - sorry I didn’t pay more attention to that.

As for the Failed to retrive cursor error message, I get 3-4 of those each second (after I start a game). That’s a lot of “spam”. If you can fix those, it would be great. They’re so many it makes it difficult to follow the rest of the messages.

Now I still get these, with 0.4.1:

ERROR 2016-10-19 10:19:19,601 [http]:Unable to connect to server ( < urlopen error [Errno -2] Name or service not known>
WARNING 2016-10-19 10:19:19,601 [resources]:Unable to get games from API

The set_cursor stuff can be safely ignored, sorry for the noise it produces, I have now removed everything related to it and won’t be here in next release.

This is more troublesome, can you access from a browser? Do you have anything special in your internet connection that could explain that? (Proxy, unreliable wifi, etc)

It works from the browser, and I’m also authenticated there. I see “Django REST framework” and the rest of the content that I would expect to see.

In addition to that, I got this by trying to run Prince of Persia (Linux):

Unrecognized option: -glamor
use: X [:< display>] [option]
-a # default pointer acceleration (factor)
-ac disable access control restrictions
SDL_Init: No available video device

And it worked last night, but I can’t remember if I tried it before or after I upgraded to 0.4.1. I can say for sure, though, that I’ve seen this happening with a previous build of 0.4.0.

Maybe this will help:

nicu@Nicu-PC ~ $ inxi -SGx
System: Host: Nicu-PC Kernel: 4.4.0-42-generic x86_64 (64 bit gcc: 4.8.4)
Desktop: MATE 1.12.0 (Gtk 3.10.8~8+qiana) Distro: Linux Mint 17.3 Rosa
Graphics: Card: Intel HD Graphics 530 bus-ID: 00:02.0
Display Server: X.Org 1.17.1 driver: intel Resolution: 1920x1080@60.0hz
GLX Renderer: Mesa DRI Intel Skylake DT GT2 GLX Version: 3.0 Mesa 10.5.9 Direct Rendering: Yes

nicu@Nicu-PC ~ $ lsmod | grep -e “drm|i915”
i915_bpo 1306624 5
intel_ips 20480 1 i915_bpo
drm_kms_helper 151552 1 i915_bpo
drm 360448 6 i915_bpo,drm_kms_helper
fb_sys_fops 16384 1 drm_kms_helper
syscopyarea 16384 1 drm_kms_helper
sysfillrect 16384 1 drm_kms_helper
sysimgblt 16384 1 drm_kms_helper
i2c_algo_bit 16384 2 igb,i915_bpo
video 40960 2 i915_bpo,asus_wmi

Did you enable the “Use Xephyr” option? That looks like Xephyr! (And it seems that the version of Xephyr shipped with Mint isn’t compatible with Lutris but that’s another Problem, you don’t need Xephyr for PoP)

1 Like

Indeed, that was the problem. Thanks! :slight_smile:

Would you like me to test something else?

Outside of those networking issues, you seem all good. I’d really like to find out why you can’t access the API from the client though