Install links not working: Address not understood

I have a fresh install of linux mint with wine installed. I installed Lutris fine, but when I click “install” for any game it opens a new window in firefox saying address not understood.
I tried linking my account, but it didn’t fix it.
I also tried adding “;/usr/bin/lutris” to my about:config in firefox, but that also didn’t fix it.
I tried searching online, but I couldn’t find anything.

Anyone have any idea what to do?



First of all, we need more information on that:
Which distribution you are on and which desktop environment?

Did you try adding lutris to your mimeTypes.rdf file?

mine was located in ~/.mozilla/firefox/7ntrs2kd.default/mimeTypes.rdf

I added:
<RDF:li RDF:resource="urn:scheme:lutris"/>
to the <RDF:Seq RDF:about="urn:schemes:root">-node

and added a new node looking something like this as well:
<RDF:Description RDF:about="urn:scheme:\utris" NC:value="lutris">
<NC:handlerProp RDF:resource="urn:scheme:handler:lutris"/>

After this firefox actually asked me about which application to use when clicking the lutris install link.

I’m using Debian without any desktop environment btw.
And I have no idea whether this is the “right way” to do it. But it worked for me.

Same issue here.
Linux Mint 18, followed Ubuntu install instructions on the site as of today.

What worked for me was adding a boolean to about:config (right click and select New > Boolean) named network.protocol-handler.expose.lutris setting it to false. Then when I tried to install a game Firefox asked me what application to use and I set it to lutris.


To FifteenthPen. Previously set to false the key named network.protocol-handler.expose-all. This will make Firefox ask for the application for any link. When you try to install, Firefox ask you for the application to use and you can set lutris and you can check in the checkbox "Remember this apllication…
After this, you can set to “true” the key named network.protocol-handler.expose-all.

Worked for me, thanks.

Yeah… for me the program will not even run… Im running ubuntu 16.04, when I go to run it it says :“Your Linux distribution is too old, Lutris won’t function properly” and in the terminal if I run it in the terminal it says :

Traceback (most recent call last):
File “/usr/bin/lutris”, line 33, in
from lutris.gui.application import Application
File “/usr/lib/python3/dist-packages/lutris/gui/”, line 42, in
from .lutriswindow import LutrisWindow
File “/usr/lib/python3/dist-packages/lutris/gui/”, line 42, in
class LutrisWindow(Gtk.ApplicationWindow):
File “/usr/lib/python3/dist-packages/lutris/gui/”, line 266, in call
_register_template(cls, template_bytes)
File “/usr/lib/python3/dist-packages/lutris/gui/”, line 76, in _register_template
raise TypeError(“Requires PyGObject 3.13.2 or greater”)
TypeError: Requires PyGObject 3.13.2 or greater"

Please help!!! I really want to get this working!!!

@Craftygeek Lutris shouldn’t have this issue on Ubuntu 16.04, that something you would see on Ubuntu 14.04 so this is very weird.

Do you have a solution?

Oh My GOD I am soooo sorry, Im running 14.04 not 16.04 this is a :man_facepalming: momment!

There we go :smiley:
Consider upgrading to 16.04, 14.04 is pretty old now.

Yep I have sorry for wasting everybody’s time!

Thanks, this worked great for me.