How to run add-on in Magic the Gathering: Arena?

Hello, I recently installed Magic the Gathering: Arena (MTGA) successfully and it plays beautifully through Lutris. It’s fairly common for MTGA players to track their games and cards using tools such as MTG Assistant and Companion. These are separate applications that somehow interface with the running MTGA executable.

I’m fairly new to Lutris, but it seems like Lutris creates separate “runners” which are customized wine processes. I found the one for MTGA in ~/.local/share/lutris/runners/wine/lutris-mtga-5.0-x86_64/bin/wine. I tried running that with my installer for the Companion, but all that happens is a window pops up from Wine saying “Installing, please wait” and then quits. I’m guessing this actually installed it.

I do see the companion installed at ~/Games/magic-the-gathering-arena/drive_c/users/<my user name> /Local\ Settings/Application\ Data/Programs/untapped-companion/\ Companion.exe. If I run ~/.local/share/lutris/runners/wine/lutris-mtga-5.0-x86_64/bin/wine ~/Games/magic-the-gathering-arena/drive_c/users/<my user name> /Local\ Settings/Application\ Data/Programs/untapped-companion/\ Companion.exe I can see a bunch of output but no window ever appears.

If I run the same setup program using standard wine and not the runner from MTGA, the app installs fine but isn’t linked to the same disk as the one that’s created by the MTGA runner.

How can I run either of these add-on/companion apps while MTGA is running?



Hey @comminutus , I had the same need as you and some months ago I followed this reddit comment in order to successfully install & run the Companion.

To quote :

Installing it
WINEPREFIX=~/Games/magic-the-gathering-arena/ WINEESYNC=1 ~/.local/share/lutris/runners/wine/lutris-mtga-5.0-x86_64/bin/wine ~/Games/magic-the-gathering-arena/drive_c/path/to/installer
Running it
WINEPREFIX=~/Games/magic-the-gathering-arena/ WINEESYNC=1 ~/.local/share/lutris/runners/wine/lutris-mtga-5.0-x86_64/bin/wine ~/Games/magic-the-gathering-arena/drive_c/users/username/Local\ Settings/Application\ Data/Programs/untapped-companion/\ Companion.exe

But there has been an update a few weeks ago, and now, when I run the Companion, it fails to launch any interface…

I messed with the settings a little bit, not sure exactly what I did, but at one point I saw a popup window that said something like “Javascript Error” with a stack trace and this error message at the top: " EINVAL: invalid argument, uv_pipe_open when starting code from WSL".

What’s odd is that it installs fine using the standard Wine distribution, but that wine instance can’t see my Magic Arena instance.

Go for MTGA Tool. Is the best tracker for MTGA.

MTG Arena Tool