How to install an MS.NET framework through Winetricks

I’m using Lutris and Wine to attempt to install a Windows app called Logos.exe to use on my POP OS Linux system. When I run the app it opens an initial graphic and then a window pops up saying that it needs version 4.7.2 of the MS NET framework. (See the attachment below.) Here is what I did:

  1. As part of my setup in Lutris, I chose/selected the app’s icon.
  2. I then pulled up Winetricks (through the Lutris menu) and navigated to the screen where I can choose which NET framework. The 4.0 framework was already in use.
  3. I unselect the 4.0 version and select the 4.7.2 version.
  4. I save my setup and exit to the Lutris main window and then run the app, getting the same result with the app stalled.

I can’t seem to get past this point. What am I doing wrong?

When I go back to check my setup, the 4.0 framework is still in place and the 4.7.2 version is unchecked. Honestly, I don’t know if this is a Winetricks problem or a Lutris issue. More likely it’s a “stupid user” issue. Help!

Screenshot from 2022-09-26 10-53-48

Hello, jreagan.

Navigate dropdown arrow next to a wine logo (it is located to the right next to the games Play button).


Then go as follows: Wine Configuration >> Select the default wine prefix >> Install a windows DLL or component. Then scroll down until you see a package named dotnet472 and click the Ok button.

OP is saying that he has followed the steps you suggested (it is in the original post) but 4.7.2 never actually gets installed. I tried this myself to check and can confirm that 4.7.2 won’t install with the newer runners.

@jhu Yes, I’ve been through that process several times. Is there a workaround that can get me up and running with my application? Right now I’m using an older, unsupported version. It works, but who knows for how long.

My only suggestion is try an older version of Wine. Use the ProtonUp tool to install the oldest version you can find (Wine not the Wine GE versions) and see if it will allow the 4.7.2 to be installed.