Back to the main site

Guild Wars 2 Launcher issue since latest update (19 JUL 2022)

While I doubt that it’s a hardware issue, if you have another mouse available it wouldn’t hurt to check if the problem is still present when using a different mouse.
You can also use this tool (it runs in the browser) to verify that your mouse clicks are being registered correctly.

As for potential software causes, do you have any background applications or overlays that might steal the mouse focus when right clicking? Perhaps you could try to close as many background applications as possible and see if the problem persists?

I tried with a different mouse, and also with all other programs closed, no luck. I also tried the mouse tool you mentioned and my mouse checked out fine.

For good measure I rebooted before trying it with all other programs closed.

The only other game I launch from Lutris is League of Legends, the mouse works fine in LoL.

After looking around on the GW2 forums, it seems that some players occasionally run into this bug and it doesn’t seem like there is a consistent way to fix the issue.

Some suggestions are switching the game to exclusive fullscreen if you are running in borderless windowed mode, or perhaps disabling desktop effects in the Lutris configuration for the game. You could also try running the game in a virtual desktop, although I’m a bit at a loss as to how to resolve this issue…

I installed a new copy by editing the script on lutris.net with

esync: false
version: lutris-fshack-7.2-x86_64

with esync: true the installer would crash out before there was a visible gui.

The mouse issue is fixed in the new install, thanks for the help.

1 Like

I changed the version from

lutris-GE-Proton7-1-x86_64

to

lutris-fshack-7.2-x86_64

Still doesn’t work, unfortunately.
The launcher is visible, and interactive. I can even log in.
But after a short period the launcher freezes and crashes.

I even managed to get past the mark for “ready to play”.
Clicking the play button opens the gw2 client, but it immediately crashed then, too.

Any suggestions?

I could fix it in my case. Here’s what I did:

  1. Go to: https://lutris.net/games/guild-wars-2/
  2. Select the drop down arrow next to the “Install” button
  3. Right mouse button over “Download Script”
  4. Select the destination
  5. Now here’s the tricky thing, once you’ve downloaded the script, (I think it’s not necessary to do both, but I did just in case) you have to edit the text → lutris-GE-Proton7-1-x86_64 and replace it exactly for → lutris-7.2-2-x86_64 after that just save the file
  6. Be aware that’s 7.2-2 not 7.2
  7. Open Lutris
  8. Top-left button → +
  9. Install from a local install script → Select your saved script
  10. Follow the installer steps

FINAL NOTES

After some testing, neither the current version stated on the script by default nor 7.2 work with Gw2, don’t know why. For me it worked when I used the version 7.2-2.

As for the frozen launcher, it’s a bit tricky but it should work. Try not to mess a lot with it. I don’t know the reason either but it’s been a thing since a while ago.

I hope it works for you guys!

Edit: (a small thing I noticed is, if you enable virtual desktop, the launcher stops hanging, however I’m not sure if it can generate some kind of performance issue) (I also found the launcher works without issues using KDE, for some reason it only hangs on Gnome)

2 Likes

This worked.
Using 7.2-2 was the solution. Thank you very much!

I submitted the changed script that worked for me for moderation, giving credits to you @Nuxmin and @NSWarsnake .

Not working here with all the suggested versions of proton, i get as far as downloading it until like 5 percent it freezes and I don’t have the time to let it sit there frozen without seeing the progress on it, looks like i will have to go back to windows for the time being, until it’s fixed, but i fear it won’t work on linux anymore because the game is 10 years old.

you need a wine with child window support. the default from TKG works. there is no version with child window support in lutris versions?

The game is 10 years old, but it is now working on DX11 not DX9, they are working on new DLCs and now they have the steam integration.
Give us more Infos about your System, so we can help you too.