Back to the main site

Can't paste from clipboard in Origin

Hey mates!

Got Origin running with some games (like Battlefield/front and so on)

Everything runs fine, but I have to write my password every time I run the Origin app. Wouldn’t be that bad, but I simply can’t copy/paste into the password field (or any other field)

I tried Ctrl+V, as well as any other combination with Paste and other stuff - it simply doesn’t work.

Is this a known problem with a fix?

Don’t want to manually write my password all the time.

1 Like

I had a similar problem a while back with something. Unfortunately, I don’t remember what the fix was. If I remember I will post back. I do know there was a fix, and it was fairly simple.

I think this was a problem I had right after I switched from Windows to Linux. It was a fresh Debian install and I was missing a lot of packages, mostly 32 bit and drivers. The only thing I can suggest is make sure you enable multiarch, you can google that, and I would also suggest that you install Steam.

The reason why I say install Steam is that Steam does a pretty good job of installing drivers and packages you will need. Once you’ve installed Steam, you can uninstall it, as long as you don’t uninstall the packages that you installed with it. You could also look up the depends for Steam, and try installing those individually.

All this will depend on your distro of course.

The other thing to look at is common culprits like Esync. If you have enabled that, try disabling that. If you are running an fshack version of Lutris wine, try switching to the standard version. Try disabling the Lutris runtime, or toggle the switch “Prefer system libraries”.

Are you using keepassxc perhaps?
There was a bug with it and it got fixed, but only for gog and humble.
From the code:

dialog.set_modal(True)
dialog.show()

it seems like a rather simple fix.

Do you have an account on github? If you do, could you please report the issue?

Origin is a 32-bit application, it literally will not work if you don’t have multiarch. This isn’t it.

I don’t think you found a fix, either, you can’t copy and paste into Origin that I know of, it’s a known issue.

The “workaround” is to just click the “Remember me” checkbox that keeps you logged in so you don’t have to log in every time, but that’s if you only have one prefix with origin in it, because you can only be logged into one client at a time.