Back to the main site

Battlefield 4 Punk Buster kicks me

Okay so I reinstalled everything on one ext4 partition.

Still doesn’t work. In a few weeks I’m going to replace my laptop’s HDD for an SSD, maybe it will magically work then.

What distro are you on? Which windows version are you set to in winecfg? Wine version / dxvk version? I’ll test what I can and see what makes a difference.

Arch linux 5.1.9
Wine version 4.9, 64bit, Windows version set to Windows 7 (I’m going to try Windows 10 and report what happens)
DXVK version 1.2.1 (but I noticed 1.2.2 came out today, will test again)

EDIT:
I tested with Windows 10 and version 1.2.2 of DXVK, nothing changed.
I also noticed the game folder wasn’t actually in the wine directories, but outside of it. So Origin still thought the game was on another drive while it was actually on the same partition. I fixed this but no changes.

Good news:

I found that if I install the Windows version of Punkbuster and install punkbuster for BF4 from the standalone pb app (pbsetup.exe), like @Rakanoza said, and also change my wine version to ‘tkg-protonified-3.21-x86-64’ instead of the latest version of wine (4.9), I have a ping in-game. In the server browser, I still get the same ping next to any server, but in-game it’s the correct value. So no more getting kicked with this wine version.

I did notice a slight performance drop with the older version of wine: every 1-5 seconds, I get a stutter that can last up to about a second. I didn’t get this with the latest version of wine.

EDIT: turns out the stuttering was because of thermal throttling. Fixed by lowering maximum CPU frequency.

If I use the latest version of wine + installing standalone punkbuster, I don’t get kicked by punkbuster anymore but a lot of server admins don’t like me having no ping value in-game, kicking me after a minute or two.

What wine version are you using?

Hi

I’m facing the same issue of punkbuster kicking me out of the game.

So I first installed “pbsvc.exe” but after it wasn’t working (no ping) I installed “pbsetup.exe” but unfortunately also this doesn’t seem to work as it should and again I got kicked out of the game after 10sec. (no ping).
I also changed the wine version to “tkg-protonified-3.21-x86-64” but still I have no ping in game :frowning:

OS: Ubuntu 18.04 bionic
Install path: Z:\media[USER]\Games\battlefield-1\drive_c\Program Files (x86)\Origin Games\Battlefield 4
Format: ext4
DXVK: v1.2.2

Would somebody know how I could solve this issue?

Thanks a lot!

@jani86 Did you install the exe’s with lutris’ ‘Run EXE inside wine prefix’ function?

Also, after I installed pbsetup.exe, it created a folder called ‘pb’ in the game’s directory. Do you have this folder?

Right now, i’m using the newer ‘ge-protonified-4.10-x86_64’ version of wine. Maybe this one will work for you. You can add new wine versions on the left in the ‘runners’ section in lutris.

Let me know if this works. I don’t really know what could cause this issue for you.

@zjeffer thanks a lot for your answer!

yes, I installed the “pbsetup.exe” by using the wine prefix and there’s also a folder called “pb” in the game’s directory.
somehow after starting the game a couple of times in a row it worked (with both wine versions 3.21 and 4.10) and also the ping is shown now.

the issue is solved :slight_smile:

PS: what I also did is (this might not be the solution but maybe worth to mention), that I directly linked the executable of the game options to the bf4.exe

“drive_c/Program Files (x86)/Origin Games/Battlefield 4/bf4.exe”

1 Like

Glad it seems to work for you guys, I said I would check some stuff out and never came back hehe

Somehow a couple of weeks ago it stopped showing my ping again (I think after an Origin update).
I’ve tried pretty much everything again but can’t get it to work.

@jani86 does it still work for you?

I also encounter the missing ping problem. Does everyone encounter this problem or is there a fix?

Same issue, no Ping is shown but Punkbuster Service runs.

Same issue here .Arch linux
Amd card rx 590 with mesa drivers . No ping with Nvidia too ?

I have a GTX 1050, but either way I don’t see how a different GPU brand could make a difference.

cause it worked when i used amdpro driver . Now im using Mesa-aco-git

That sounds very weird. I’m using the proprietary nvidia driver on arch linux and I still have not found a solution for the record.

I’ve always used the nvidia proprietary driver and as I’ve posted earlier, it used to work but suddenly it stopped working, I think after an origin or game update.

Is it only arched based distros the no ping issue? I have disables all firewalls and nothing .

I don’t own bf4, but I did have some trouble updating Origin.
After adding the following ports:

  • TCP: 80, 443, 9960-9969, 1024-1124, 3216, 18000, 18120, 18060, 27900, 28910, 29900

  • UDP:1024-1124, 18000, 29900

the issues with updating were resolved.
I hope this help.

i have this problem, too. My only solution is: use for origin - lutris jedi 4.2. i have tested until version 5.6.2 but only jedi 4.2 works without ping-problem.

For Ubuntu, try this…

This worked for me and I’m on Mint 19. My ping shows properly now.